Back to overview
Resolved
Timeline is restricted
Apr 17, 2026 at 4:24pm UTC
Affected services
Zigaflow App
Resolved
Apr 29, 2026 at 4:40pm UTC
The timeline on order pages is now back up and running.
Affected services
Created
Apr 17, 2026 at 4:24pm UTC
Due to the incident, we are currently only displaying the timeline for the selected order. Linked orders are not being shown at this time. We are actively working to restore full functionality.
Affected services